$re = '/\b(?=[A-Z0-9]{7}\b)[A-Z0-9]+[0-9][A-Z0-9]*/m';
$str = 'I want this nr A7A3G1A but not this ANTENNA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);