re = /\b(?=[A-Z0-9]{7}\b)[A-Z0-9]+[0-9][A-Z0-9]*/m
str = 'I want this nr A7A3G1A but not this ANTENNA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end