#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "http://www\.myurl\.com/\?action=joingiveaway&id=([0-9]+)"
Local $sString = " " & @CRLF & _
"" & @CRLF & _
" <DIV>" & @CRLF & _
" <H2><A style="COLOR: black" href="http://www.myurl.com/?action=viewgiveaways&id=287">New car Giveaway</A></H2></DIV>" & @CRLF & _
" <DIV style="MARGIN-TOP: 6px">The Winner of this giveaway will win a new car!</DIV>" & @CRLF & _
" <DIV class=box_round style="BORDER-TOP: red 1px solid; BORDER-RIGHT: red 1px solid; BORDER-BOTTOM: red 1px solid; PADDING-BOTTOM: 8px; PADDING-TOP: 8px; PADDING-LEFT: 8px; BORDER-LEFT: red 1px solid; MARGIN-TOP: 10px; PADDING-RIGHT: 8px">" & @CRLF & _
" <DIV><B>Special Requirement : </B></DIV>" & @CRLF & _
" <DIV style="MARGIN-TOP: 2px">You need to have earned atleast <B style="COLOR: blue">1000 Coins </B>in total to enter this Giveaway </DIV>" & @CRLF & _
" <DIV style="COLOR: green; MARGIN-TOP: 2px">Your total coin earnings is 21707 </DIV></DIV>" & @CRLF & _
" <DIV style="MARGIN-TOP: 6px"><B>Entry Fee : 20 Coins</B></DIV>" & @CRLF & _
" <DIV style="MARGIN: 6px"><A class=cssbutton style="COLOR: white" href="http://www.myurl.com/?action=joingiveaway&id=287">Enter Giveaway</A><BR><SMALL>You have 0 entries</SMALL></DIV></DIV>" & @CRLF & _
" <DIV style="FLOAT: right">" & @CRLF & _
" <DIV>Group : Everyone</DIV>" & @CRLF & _
" <DIV>Multiple Entries : No</DIV>" & @CRLF & _
" <DIV>Total Entries : <A href="http://www.myurl.com/?action=viewentries&giveawayid=287">4</A></DIV>" & @CRLF & _
" <DIV>Max Entries : 100</DIV>" & @CRLF & _
" <DIV>Start Date : Jan 23 2013</DIV>" & @CRLF & _
" <DIV><A href="http://www.myurl.com/index.php?action=faq#coins" target=_blank>How To Earn Coins?</A></DIV></DIV>" & @CRLF & _
" <DIV style="CLEAR: both"></DIV></DIV></DIV></DIV>" & @CRLF & _
" <DIV class=index-left style="FLOAT: right; PADDING-TOP: 15px; PADDING-RIGHT: 23px">" & @CRLF & _
" <DIV class=left-section>" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")