# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"http://www\.myurl\.com/\?action=joingiveaway&id=([0-9]+)"
test_str = (" \n\n"
" <DIV>\n"
" <H2><A style=\"COLOR: black\" href=\"http://www.myurl.com/?action=viewgiveaways&id=287\">New car Giveaway</A></H2></DIV>\n"
" <DIV style=\"MARGIN-TOP: 6px\">The Winner of this giveaway will win a new car!</DIV>\n"
" <DIV class=box_round style=\"BORDER-TOP: red 1px solid; BORDER-RIGHT: red 1px solid; BORDER-BOTTOM: red 1px solid; PADDING-BOTTOM: 8px; PADDING-TOP: 8px; PADDING-LEFT: 8px; BORDER-LEFT: red 1px solid; MARGIN-TOP: 10px; PADDING-RIGHT: 8px\">\n"
" <DIV><B>Special Requirement : </B></DIV>\n"
" <DIV style=\"MARGIN-TOP: 2px\">You need to have earned atleast <B style=\"COLOR: blue\">1000 Coins </B>in total to enter this Giveaway </DIV>\n"
" <DIV style=\"COLOR: green; MARGIN-TOP: 2px\">Your total coin earnings is 21707 </DIV></DIV>\n"
" <DIV style=\"MARGIN-TOP: 6px\"><B>Entry Fee : 20 Coins</B></DIV>\n"
" <DIV style=\"MARGIN: 6px\"><A class=cssbutton style=\"COLOR: white\" href=\"http://www.myurl.com/?action=joingiveaway&id=287\">Enter Giveaway</A><BR><SMALL>You have 0 entries</SMALL></DIV></DIV>\n"
" <DIV style=\"FLOAT: right\">\n"
" <DIV>Group : Everyone</DIV>\n"
" <DIV>Multiple Entries : No</DIV>\n"
" <DIV>Total Entries : <A href=\"http://www.myurl.com/?action=viewentries&giveawayid=287\">4</A></DIV>\n"
" <DIV>Max Entries : 100</DIV>\n"
" <DIV>Start Date : Jan 23 2013</DIV>\n"
" <DIV><A href=\"http://www.myurl.com/index.php?action=faq#coins\" target=_blank>How To Earn Coins?</A></DIV></DIV>\n"
" <DIV style=\"CLEAR: both\"></DIV></DIV></DIV></DIV>\n"
" <DIV class=index-left style=\"FLOAT: right; PADDING-TOP: 15px; PADDING-RIGHT: 23px\">\n"
" <DIV class=left-section>\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.