const regex = /http://www\.myurl\.com/\?action=joingiveaway&id=([0-9]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('http:\/\/www\\.myurl\\.com\/\\?action=joingiveaway&id=([0-9]+)', 'g')
const str = `
<DIV>
<H2><A style="COLOR: black" href="http://www.myurl.com/?action=viewgiveaways&id=287">New car Giveaway</A></H2></DIV>
<DIV style="MARGIN-TOP: 6px">The Winner of this giveaway will win a new car!</DIV>
<DIV class=box_round style="BORDER-TOP: red 1px solid; BORDER-RIGHT: red 1px solid; BORDER-BOTTOM: red 1px solid; PADDING-BOTTOM: 8px; PADDING-TOP: 8px; PADDING-LEFT: 8px; BORDER-LEFT: red 1px solid; MARGIN-TOP: 10px; PADDING-RIGHT: 8px">
<DIV><B>Special Requirement : </B></DIV>
<DIV style="MARGIN-TOP: 2px">You need to have earned atleast <B style="COLOR: blue">1000 Coins </B>in total to enter this Giveaway </DIV>
<DIV style="COLOR: green; MARGIN-TOP: 2px">Your total coin earnings is 21707 </DIV></DIV>
<DIV style="MARGIN-TOP: 6px"><B>Entry Fee : 20 Coins</B></DIV>
<DIV style="MARGIN: 6px"><A class=cssbutton style="COLOR: white" href="http://www.myurl.com/?action=joingiveaway&id=287">Enter Giveaway</A><BR><SMALL>You have 0 entries</SMALL></DIV></DIV>
<DIV style="FLOAT: right">
<DIV>Group : Everyone</DIV>
<DIV>Multiple Entries : No</DIV>
<DIV>Total Entries : <A href="http://www.myurl.com/?action=viewentries&giveawayid=287">4</A></DIV>
<DIV>Max Entries : 100</DIV>
<DIV>Start Date : Jan 23 2013</DIV>
<DIV><A href="http://www.myurl.com/index.php?action=faq#coins" target=_blank>How To Earn Coins?</A></DIV></DIV>
<DIV style="CLEAR: both"></DIV></DIV></DIV></DIV>
<DIV class=index-left style="FLOAT: right; PADDING-TOP: 15px; PADDING-RIGHT: 23px">
<DIV class=left-section>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}