#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:newProductsInfo: |\G(?!^)).*?\K\[\d+].*?(?=,\[\d+]|$)"
Local $sString = "newProductsInfo: [[$39 OFF] - Ear Cuffs - Low in Stock,FREE Box (Previously $30),The Club: Exclusive VIP,[Exclusive Offer] / Discounted Mystery Box]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")