const regex = /(?:newProductsInfo: |\G(?!^)).*?\K\[\d+].*?(?=,\[\d+]|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:newProductsInfo: |\\G(?!^)).*?\\K\\[\\d+].*?(?=,\\[\\d+]|$)', 'g')
const str = `newProductsInfo: [[\$39 OFF] - Ear Cuffs - Low in Stock,FREE Box (Previously \$30),The Club: Exclusive VIP,[Exclusive Offer] / Discounted Mystery Box]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}