re = /(?:newProductsInfo: |\G(?!^)).*?\K\[\d+].*?(?=,\[\d+]|$)/
str = 'newProductsInfo: [[$39 OFF] - Ear Cuffs - Low in Stock,FREE Box (Previously $30),The Club: Exclusive VIP,[Exclusive Offer] / Discounted Mystery Box]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end