package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\/]+$`)
var str = `https://test.com/cancel/AA7ES34QSAGF563N
https://test.com/move/AA7ES34QSAGF563N`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}