re = /[^\/]+$/m
str = 'https://test.com/cancel/AA7ES34QSAGF563N
https://test.com/move/AA7ES34QSAGF563N'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end