$re = '/[^\/]+$/m';
$str = 'https://test.com/cancel/AA7ES34QSAGF563N
https://test.com/move/AA7ES34QSAGF563N';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);