using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""authorization\\\\\\\"":\\\\\\""(.+)\\\\\\""";
string input = @",\\\""authorization\\\"":\\\""Bearer xxxxxx.yyyyy.fff-dddd\\\"",
,\\\""authorization\\\"":\\\""xxxxxx.yyyyy.fff-dddd\\\"",";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}