using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<whoName>(?!self)[a-z0-9]*<\/whoName>";
string input = @"<whoName>other</whoName>
<whoName>self</whoName> ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}