$re = '/<whoName>(?!self)[a-z0-9]*<\/whoName>/';
$str = '<whoName>other</whoName>
<whoName>self</whoName> ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);