re = /<whoName>(?!self)[a-z0-9]*<\/whoName>/
str = '<whoName>other</whoName>
<whoName>self</whoName> '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end