#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([a-z]+\(([^()]*)\))"
Local $sString = "" & @CRLF & _
                "eq(a,a),eq(b,b)" & @CRLF & _
                "eq(b,b)" & @CRLF & _
                "or(eq(a,a),eq(b,b))" & @CRLF & _
                "and(or(eq(a,a),eq(b,b)),or(eq(a,a),eq(b,b)))" & @CRLF & _
                "and(eq(a,a),or(eq(b,b),eq(c,c))" & @CRLF & _
                ""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")