import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-z]+\\(([^()]*)\\))";
final String string = "\n"
+ "eq(a,a),eq(b,b)\n"
+ "eq(b,b)\n"
+ "or(eq(a,a),eq(b,b))\n"
+ "and(or(eq(a,a),eq(b,b)),or(eq(a,a),eq(b,b)))\n"
+ "and(eq(a,a),or(eq(b,b),eq(c,c))\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}