re = /([a-z]+\(([^()]*)\))/m
str = '
eq(a,a),eq(b,b)
eq(b,b)
or(eq(a,a),eq(b,b))
and(or(eq(a,a),eq(b,b)),or(eq(a,a),eq(b,b)))
and(eq(a,a),or(eq(b,b),eq(c,c))
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end