import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([1-4]\\d|[5-9])\\d*)\\+$";
final String string = "HP 400 PROONE İ3-4130T 4GB 500GB 19.5\" OB DO 792,40 679,20 582,98 USD 1.462,70 18 6+\n"
+ "HP 400 PROONE İ3-4130T 4GB 500GB 19.5\" OB DO 792,40 679,20 582,98 USD 1.462,70 18 7+\n"
+ "HP 400 PROONE İ3-4130T 4GB 500GB 19.5\" OB DO 792,40 679,20 582,98 USD 1.462,70 18 8+\n"
+ "HP 400 PROONE İ3-4130T 4GB 500GB 19.5\" OB DO 792,40 679,20 582,98 USD 1.462,70 18 9+\n"
+ "HP 400 PROONE İ3-4130T 4GB 500GB 19.5\" OB DO 792,40 679,20 582,98 USD 1.462,70 18 10+\n"
+ "HP 400 PROONE İ3-4130T 4GB 500GB 19.5\" OB DO 792,40 679,20 582,98 USD 1.462,70 18 11+\n"
+ "HP 400 PROONE İ3-4130T 4GB 500GB 19.5\" OB DO 792,40 679,20 582,98 USD 1.462,70 18 51+\n"
+ "HP 400 PROONE İ3-4130T 4GB 500GB 19.5\" OB DO 792,40 679,20 582,98 USD 1.462,70 18 61+\n"
+ "HP 400 PROONE İ3-4130T 4GB 500GB 19.5\" OB DO 792,40 679,20 582,98 USD 1.462,70 18 81+\n"
+ "HP 400 PROONE İ3-4130T 4GB 500GB 19.5\" OB DO 792,40 679,20 582,98 USD 1.462,70 18 4+\n";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}