// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(([1-4]\d|[5-9])\d*)\+$").unwrap();
let string = "HP 400 PROONE İ3-4130T 4GB 500GB 19.5\" OB DO 792,40 679,20 582,98 USD 1.462,70 18 6+
HP 400 PROONE İ3-4130T 4GB 500GB 19.5\" OB DO 792,40 679,20 582,98 USD 1.462,70 18 7+
HP 400 PROONE İ3-4130T 4GB 500GB 19.5\" OB DO 792,40 679,20 582,98 USD 1.462,70 18 8+
HP 400 PROONE İ3-4130T 4GB 500GB 19.5\" OB DO 792,40 679,20 582,98 USD 1.462,70 18 9+
HP 400 PROONE İ3-4130T 4GB 500GB 19.5\" OB DO 792,40 679,20 582,98 USD 1.462,70 18 10+
HP 400 PROONE İ3-4130T 4GB 500GB 19.5\" OB DO 792,40 679,20 582,98 USD 1.462,70 18 11+
HP 400 PROONE İ3-4130T 4GB 500GB 19.5\" OB DO 792,40 679,20 582,98 USD 1.462,70 18 51+
HP 400 PROONE İ3-4130T 4GB 500GB 19.5\" OB DO 792,40 679,20 582,98 USD 1.462,70 18 61+
HP 400 PROONE İ3-4130T 4GB 500GB 19.5\" OB DO 792,40 679,20 582,98 USD 1.462,70 18 81+
HP 400 PROONE İ3-4130T 4GB 500GB 19.5\" OB DO 792,40 679,20 582,98 USD 1.462,70 18 4+
";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}