#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?um)^[0-9\p{L}][0-9\p{L}-\.]{1,61}[0-9\p{L}]\.[0-9\p{L}][\p{L}-]*[0-9\p{L}]+$"
Local $sString = "google.com" & @CRLF & _
"masełkowski.pl" & @CRLF & _
"maselkowski.pl" & @CRLF & _
"m.maselkowski.pl" & @CRLF & _
"www.masełkowski.pl.com" & @CRLF & _
"xn--masekowski-d0b.pl" & @CRLF & _
"中国互联网络信息中心.中国" & @CRLF & _
"masełkowski.pl." & @CRLF & _
"masełk..owski.pl" & @CRLF & _
"中国互联网络信息中心.xn--masekowski-d0b" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")