import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9\\p{L}][0-9\\p{L}-\\.]{1,61}[0-9\\p{L}]\\.[0-9\\p{L}][\\p{L}-]*[0-9\\p{L}]+$";
final String string = "google.com\n"
+ "masełkowski.pl\n"
+ "maselkowski.pl\n"
+ "m.maselkowski.pl\n"
+ "www.masełkowski.pl.com\n"
+ "xn--masekowski-d0b.pl\n"
+ "中国互联网络信息中心.中国\n"
+ "masełkowski.pl.\n"
+ "masełk..owski.pl\n"
+ "中国互联网络信息中心.xn--masekowski-d0b\n";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}