import re
regex = re.compile(r"^[0-9\p{L}][0-9\p{L}-\.]{1,61}[0-9\p{L}]\.[0-9\p{L}][\p{L}-]*[0-9\p{L}]+$", flags=re.UNICODE | re.MULTILINE)
test_str = ("google.com\n"
"masełkowski.pl\n"
"maselkowski.pl\n"
"m.maselkowski.pl\n"
"www.masełkowski.pl.com\n"
"xn--masekowski-d0b.pl\n"
"中国互联网络信息中心.中国\n"
"masełkowski.pl.\n"
"masełk..owski.pl\n"
"中国互联网络信息中心.xn--masekowski-d0b\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")