import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<postcode>|(?<outward>(?<area>\\w{1,2}))(?<district>\\d\\w|\\d{1,2}))(?:\\s)?(?<inward>(?<sector>\\d)(?<unit>\\w\\w))?";
final String string = "W1J 7NT\n"
+ "DE12 8HJ\n"
+ "SW1A 1AA\n"
+ "HD7 5UZ\n"
+ "CH5 3QW\n"
+ "W2 1JB \n"
+ "PL7 1RF\n"
+ "EH99 1SB\n"
+ "G58 1SB\n"
+ "JE3 1EP\n\n"
+ "GIR 0AA";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}