const regex = /^(?<postcode>|(?<outward>(?<area>\w{1,2}))(?<district>\d\w|\d{1,2}))(?:\s)?(?<inward>(?<sector>\d)(?<unit>\w\w))?/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<postcode>|(?<outward>(?<area>\\w{1,2}))(?<district>\\d\\w|\\d{1,2}))(?:\\s)?(?<inward>(?<sector>\\d)(?<unit>\\w\\w))?', 'gmi')
const str = `W1J 7NT
DE12 8HJ
SW1A 1AA
HD7 5UZ
CH5 3QW
W2 1JB
PL7 1RF
EH99 1SB
G58 1SB
JE3 1EP
GIR 0AA`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}