use strict;
my $str = 'OK THT PHP This is it 06222021
NO MTM PYT Get this content 111111';
my $regex = qr/^\w{0,2}\s\w{0,3}\s\w{0,3}\s(.*?)\s\d{6,8}\s?$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";