#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?:\(.+?\).*[\r\n]*)+$"
Local $sString = "(There) can\n(be) any" & @CRLF & _
"" & @CRLF & _
"(amount) of " & @CRLF & _
"(newlines) as" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"(long) as each " & @CRLF & _
"(line) that has " & @CRLF & _
"(content) starts " & @CRLF & _
"(with a) set of parenthesis."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")