const regex = /^(?:\(.+?\).*[\r\n]*)+$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\(.+?\\).*[\\r\\n]*)+$', 'g')
const str = `(There) can\\n(be) any
(amount) of
(newlines) as
(long) as each
(line) that has
(content) starts
(with a) set of parenthesis.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}