using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\(.+?\).*[\r\n]*)+$";
string input = @"(There) can\n(be) any
(amount) of
(newlines) as
(long) as each
(line) that has
(content) starts
(with a) set of parenthesis.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}