import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([\\S ]+\\n?.*?)([0-9]+[,.][0-9]{2})...$";
final String string = "Ben\n"
+ "1x 1.32 1.32 OK\n\n"
+ "Mark\n"
+ "3x 0.50 1.50 FAIL\n\n"
+ "Johny\n"
+ "2x 1.20 2.40 OK";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}