const regex = /^([\S ]+\n?.*?)([0-9]+[,.][0-9]{2})...$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\S ]+\\n?.*?)([0-9]+[,.][0-9]{2})...$', 'gmi')
const str = `Ben
1x 1.32 1.32 OK
Mark
3x 0.50 1.50 FAIL
Johny
2x 1.20 2.40 OK`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}