package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^\/]+)\/?$`)
var str = `http://instagram.com/p/dPWjiVtX-C/test/test/test/
http://instagram.com/p/dPWjiVtX-C`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}