$re = '/([^\/]+)\/?$/m';
$str = 'http://instagram.com/p/dPWjiVtX-C/test/test/test/
http://instagram.com/p/dPWjiVtX-C';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);