re = /([^\/]+)\/?$/m
str = 'http://instagram.com/p/dPWjiVtX-C/test/test/test/
http://instagram.com/p/dPWjiVtX-C'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end