package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[1-9]\d*(\.\d{1,2})?'?[1-9]\d*(\.\d{1,2})?"?\s*`)
var str = `52.352'9"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}