$re = '/^[1-9]\d*(\.\d{1,2})?\'?[1-9]\d*(\.\d{1,2})?"?\s*/';
$str = '52.352\'9"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);