// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"^[1-9]\d*(\.\d{1,2})?'?[1-9]\d*(\.\d{1,2})?"?\s*"#).unwrap();
let string = "52.352'9\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}