$re = '/(?<=^|\s)"[A-Za-z\s\,\.]+"(?=$|\s)/';
$str = 'hello "hello my name is Paul. I from Bobruisk trhjrthiruthurihtyruihyruithy" "hello" trhrthv "vfvfv" "ferrg"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);