using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[A-Z])(?=.*[a-z])(?!.*[A-Z][A-Z])(?!.*[a-z][a-z]).{10,15}$";
string input = @"aA1234567890AA
aA1234567890A
aA1234567890aa
67890AaAaAaAaAa
123456789123
1234567891Aa
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}