re = /^(?=.*[A-Z])(?=.*[a-z])(?!.*[A-Z][A-Z])(?!.*[a-z][a-z]).{10,15}$/m
str = 'aA1234567890AA
aA1234567890A
aA1234567890aa
67890AaAaAaAaAa
123456789123
1234567891Aa
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end