import re
regex = re.compile(r"^(?=.*[A-Z])(?=.*[a-z])(?!.*[A-Z][A-Z])(?!.*[a-z][a-z]).{10,15}$", flags=re.MULTILINE)
test_str = ("aA1234567890AA\n"
"aA1234567890A\n"
"aA1234567890aa\n"
"67890AaAaAaAaAa\n"
"123456789123\n"
"1234567891Aa\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")