const regex = /(?<=.{3}).(?=[^@]*?@)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=.{3}).(?=[^@]*?@)', 'g')
const str = `nileshkemse@gmail.com`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);