use strict;
my $str = 'nileshkemse@gmail.com';
my $regex = qr/(?<=.{3}).(?=[^@]*?@)/p;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";