re = /(?<=.{3}).(?=[^@]*?@)/
str = 'nileshkemse@gmail.com'
subst = '*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result