# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s+\|\s+.*$//gm;t' <<< "xxx:yyy | AAA GJGJDJG JHGJGJGJ
xxx:yyy | AAA KJHKHDKJHK JKHKJHD
xxx:yyy | AAA KKJHDJKHKJKF
xxx:yyy | AAA KJHKDHKDFKJDHKJHK
"