#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s+\|\s+.*$"
Local $sString = "xxx:yyy | AAA GJGJDJG JHGJGJGJ" & @CRLF & _
"xxx:yyy | AAA KJHKHDKJHK JKHKJHD" & @CRLF & _
"xxx:yyy | AAA KKJHDJKHKJKF " & @CRLF & _
"xxx:yyy | AAA KJHKDHKDFKJDHKJHK" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)