$re = '/\s+\|\s+.*$/m';
$str = 'xxx:yyy | AAA GJGJDJG JHGJGJGJ
xxx:yyy | AAA KJHKHDKJHK JKHKJHD
xxx:yyy | AAA KKJHDJKHKJKF
xxx:yyy | AAA KJHKDHKDFKJDHKJHK
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;