using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+\|\s+.*$";
string substitution = @"";
string input = @"xxx:yyy | AAA GJGJDJG JHGJGJGJ
xxx:yyy | AAA KJHKHDKJHK JKHKJHD
xxx:yyy | AAA KKJHDJKHKJKF
xxx:yyy | AAA | GJGJDJG | JHGJGJGJ
xxx:yyy | AAA KJHKDHKDFKJDHKJHK
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}