package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s+\|\s+.*$`)
var str = `xxx:yyy | AAA GJGJDJG JHGJGJGJ
xxx:yyy | AAA KJHKHDKJHK JKHKJHD
xxx:yyy | AAA KKJHDJKHKJKF
xxx:yyy | AAA | GJGJDJG | JHGJGJGJ
xxx:yyy | AAA KJHKDHKDFKJDHKJHK
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}