const regex = /\s+\|\s+.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+\\|\\s+.*$', 'gm')
const str = `xxx:yyy | AAA GJGJDJG JHGJGJGJ
xxx:yyy | AAA KJHKHDKJHK JKHKJHD
xxx:yyy | AAA KKJHDJKHKJKF
xxx:yyy | AAA | GJGJDJG | JHGJGJGJ
xxx:yyy | AAA KJHKDHKDFKJDHKJHK
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);